Главная категория > Штрих-М

1C Розница + Штрих-LitePOS+ЕГАИС

(1/3) > >>

drfaust:
Не знаю, заводить новую тему или нет - потом можно будет разделить.

Наконец-то наши клиенты разродились на ЕГАИС-ТТН. Клиент оказался не тот, на кого расчитывал.
Конфиг - 1С Розница базовая + Штрих-ЛайтПОС-2.
В Рознице (есессно последняя 2,1,9,20) накладная прошла на ура, причём с разногласиями (не приехал ящик белебеевской по 0.5). И тут же захотелось пробить боевой чек через ЕГАИС, к тому же и з/п получил.
Снимаю отчёт о продажах, в 1С в настройках выставляю дату начала работы через ЕГАИС на 20,02,16. В ПОС заливаю последний минирмк(для се 6.0), выставляю настройки для егаиса, заливаю из 1с товары с полной очисткой старых - новые пузыри(в том числе и те, которых ранее небыло) проводятся как обычно, т.е без запроса QR. Смотрю в товар на ПОСе - по эгоисту нет ничего - не стоит галка во второй вкладке товара, нет и других реквизитов(поставщик и т.п.). Просмотрел настройки УТМа - всё верно, на всяк случай пропинговал его из ПОСа - пинги скачут(ещё бы - база-то откуда заливается?)

Уже дома снова перечитал последнее скачанное со штриха руководство админа для лайтПОС (вдруг чего пропустил) - нет, всё выставил чётко.

Кто уже запускал в такой конфигурации - поделитесь где я мог накосячить?

drfaust:
В довесок. Смоделировал сейчас дома их базу.  Установил на всяк случай штриховский ДТО в полной комплектации..
В 1С Рознице установил для товара "Пузырь"(единственный с большой буквы) тип алкоголь. По идее должОн отличаться от других штучных.
Получил выгрузку:

--- Код: ---
##@@&&
#
$$$CLR
99999;4005808158065;Пузырь;Пузырь;123.00;15,000;0;0;0;0;0;;0;0;0;0;1
100000;4600999000423;Я самая Крем для костылей;Я самая Крем для костылей;456.00;10,000;0;0;0;0;0;;0;0;0;0;1
100001;4612750380125;тест-полоски;тест-полоски;125.00;125,000;0;0;0;0;0;;0;0;0;0;1
100002;4607007360913;спиртяга-75;спиртяга-75;45.00;8,000;0;0;0;0;0;;0;0;0;0;1
100003;;спиртяга-95;спирт;;;0;0;0;0;0;;0;0;0;0;1
100004;;спиртяга-75;спиртяга-75;;;0;0;0;0;0;;0;0;0;0;1

--- Конец кода ---

ЗначитЬ дело не в РМК,а в 1С...

drfaust:
Началось в колхозе утро.
Откапал в конфигураторе обработку для штриха - нигде нет упоминания об ЕГАИС-алкоголе  >:(
Спойлер
--- Код: ---
// Функция осуществляет выгрузку таблицы товаров в ККМ, подключенную в режиме Offline.
//
// Параметры:
//  ОбъектДрайвера                 - <*>
//                                 - Объект драйвера торгового оборудования.
//
//  Товары                         - <ТаблицаЗначений>
//                                 - Таблица товаров, подлежащих загрузке в ККМ.
//                                   Таблица имеет следующие колонки:
//                                     Код                        - <Число>
//                                                                - Идентификатор товара на кассе.
//                                     Штрихкод                  - <Число>, <Строка>
//                                                                - Код весового товара (для весовых товаров),
//                                                                  или штрихкод (для штучного товара).
//                                     Наименование               - <Строка>
//                                                                - Сокращенное наименование товара (для печати в чеке).
//                                     НаименованиеПолное         - <Строка>
//                                                                - Полное наименование товара (для отображения на
//                                                                мониторе).
//                                     ЕдиницаИзмерения           - <СправочникСсылка.ЕдиницыИзмерения>
//                                                                - Единица измерения номенклатуры.
//                                     Цена                       - <Число>
//                                                                - Цена номенклатуры.
//                                     Остаток                    - <Число>
//                                                                - Остаток товара на складе кассы.
//                                     ВесовойТовар               - <Булево>
//                                                                - Товар является весовым.
//
//  ЧастичнаяВыгрузка               - <Булево>
//                                  - Признак частичной выгрузки товара.
//
Функция ВыгрузитьТовары(ОбъектДрайвера, Параметры, ПараметрыПодключения, Товары, ЧастичнаяВыгрузка, ВыходныеПараметры)

// При частичной выгрузке нельзя делать новую выгрузку пока не произошла загрузка предыдущей.
Если ЧастичнаяВыгрузка И
НЕ МожноВыгружатьТовары(Параметры) Тогда
ВыходныеПараметры.Добавить(999);
ОписаниеОшибки = НСтр("ru='Нельзя сделать выгрузку. Товары предыдущей выгрузки еще не были получены ККМ-offline'");
ВыходныеПараметры.Добавить(ОписаниеОшибки);
Возврат Ложь;
КонецЕсли;

Разделитель = ПолучитьРазделитель();
Результат = Истина;

Файл = Новый ТекстовыйДокумент();

Файл.ДобавитьСтроку("##@@&&");
Файл.ДобавитьСтроку("#");

Если ЧастичнаяВыгрузка Тогда
Файл.ДобавитьСтроку("$$$ADD");
Иначе
Файл.ДобавитьСтроку("$$$CLR");
КонецЕсли;

Для Каждого ВремТовар Из Товары Цикл

ВремКод                = Формат(Число(ВремТовар.Код), "ЧЦ=13; ЧДЦ=0; ЧГ=0");
ВремАртикул            = ?(ВремТовар.Свойство("Артикул"), ПодготовитьСтроку(ВремТовар.Артикул), "");
ВремНаименование       = ?(ВремТовар.Свойство("Наименование"), ПодготовитьСтроку(ВремТовар.Наименование), ""); 
ВремНаименованиеПолное = ?(ВремТовар.Свойство("НаименованиеПолное"), ПодготовитьСтроку(ВремТовар.НаименованиеПолное), ""); 
ВремЕдиницаИзмерения   = ?(ВремТовар.Свойство("ЕдиницаИзмерения"), ВремТовар.ЕдиницаИзмерения, "");
ВремЦена               = ?(ВремТовар.Свойство("Цена"), ВремТовар.Цена, 0); 
ВремОстаток            = ?(ВремТовар.Свойство("Остаток"), ВремТовар.Остаток, 0);
ВремВесовойТовар       = ?(ВремТовар.Свойство("ВесовойТовар"), ВремТовар.ВесовойТовар, Ложь);
ВремСтавкаНДС          = ?(ВремТовар.Свойство("СтавкаНДС"), ВремТовар.СтавкаНДС, 0);

Если ТипЗнч(ВремТовар.Штрихкод) <> Тип("Массив") Тогда
Строка = ВремКод                                   + Разделитель + // Поле 1
Формат(ВремТовар.Штрихкод, "ЧЦ=13; ЧДЦ=0; ЧГ=0")   + Разделитель + // Поле 2
ВремНаименованиеПолное                             + Разделитель + // Поле 3
ВремНаименование                                   + Разделитель + // Поле 4
Формат(ВремЦена, "ЧЦ=15; ЧДЦ=2; ЧРД=.; ЧГ=0")      + Разделитель + // Поле 5
Формат(ВремОстаток, "ЧЦ=17; ЧДЦ=3; ЧРД=.; ЧГ=0")   + Разделитель + // Поле 6
"0"                                                + Разделитель + // Поле 7
?(ВремВесовойТовар, "1", "0")                      + Разделитель + // Поле 8
"0"                                                + Разделитель + // Поле 9
"0"                                                + Разделитель + // Поле 10
"0"                                                + Разделитель + // Поле 11
ВремАртикул                                        + Разделитель + // Поле 12
"0"                                                + Разделитель + // Поле 13
"0"                                                + Разделитель + // Поле 14
"0"                                                + Разделитель + // Поле 15
"0"                                                + Разделитель + // Поле 16
"1";                                                               // Поле 17
Файл.ДобавитьСтроку(Строка);
Иначе
Строка = ВремКод                                 + Разделитель +  // Поле 1
Лев(?(ВремТовар.Штрихкод.Количество() = 0, "", ВремТовар.Штрихкод[0]), 13) + Разделитель + // Поле 2
ВремНаименованиеПолное                           + Разделитель + // Поле 3
ВремНаименование                                 + Разделитель + // Поле 4
Формат(ВремЦена, "ЧЦ=15; ЧДЦ=2; ЧРД=.; ЧГ=0")    + Разделитель + // Поле 5
Формат(ВремОстаток, "ЧЦ=17; ЧДЦ=3; ЧГ=0")        + Разделитель + // Поле 6
"0"                                              + Разделитель + // Поле 7
?(ВремВесовойТовар, "1", "0")                    + Разделитель + // Поле 8
"0"                                              + Разделитель + // Поле 9
"0"                                              + Разделитель + // Поле 10
"0"                                              + Разделитель + // Поле 11
ВремАртикул                                      + Разделитель + // Поле 12
"0"                                              + Разделитель + // Поле 13
"0"                                              + Разделитель + // Поле 14
"0"                                              + Разделитель + // Поле 15
"0"                                              + Разделитель + // Поле 16
"1";                                                             // Поле 17
Файл.ДобавитьСтроку(Строка);

// Загружаем только дополнительные штрихкоды.
Счетчик = 0;
Для каждого ШтрихКод Из ВремТовар.Штрихкод Цикл
// Пропускаем первый штрихкод
Счетчик = Счетчик + 1;
Если Счетчик = 1 Тогда
Продолжить;
КонецЕсли;

Строка ="# "+  ВремКод                                              + Разделитель +
Лев(ШтрихКод, 13)                               + Разделитель +
СокрЛП(ВремНаименованиеПолное)                  + Разделитель +
СокрЛП(ВремНаименование)                        + Разделитель +
Формат(ВремЦена, "ЧЦ=15; ЧДЦ=2; ЧРД=.; ЧГ=0")   + Разделитель +// Цена
""                                              + Разделитель +
""                                              + Разделитель +
""                                              + Разделитель +
""                                              + Разделитель +
?(ТипЗнч(ВремЕдиницаИзмерения) = Тип("Строка"), "1", ВремЕдиницаИзмерения.Коэффициент);
Файл.ДобавитьСтроку(Строка);
КонецЦикла;
КонецЕсли;
КонецЦикла;

Попытка
Файл.Записать(Параметры.БазаТоваров, КодировкаТекста.ANSI);
Если Не ПустаяСтрока(Параметры.ФлагВыгрузки) Тогда
Файл.Очистить();
Файл.Записать(Параметры.ФлагВыгрузки, КодировкаТекста.ANSI);
КонецЕсли;
Исключение
ВыходныеПараметры.Добавить(999);
ОписаниеОшибки = НСтр("ru='Не удалось записать файл товаров по адресу: %Адрес%'");
ВыходныеПараметры.Добавить(СтрЗаменить(ОписаниеОшибки, "%Адрес%", Параметры.БазаТоваров));
Результат = Ложь;
КонецПопытки;

Возврат Результат;

КонецФункции

--- Конец кода ---

Киньте кто ссылкой на нормальную обработку 1С Розница -> Штрих-М Кассир

drfaust:
Закосил под дурачка - http://forum-1c.ru/index.php?topic=60530.new#new
Розница-то базовая у клЫента. Я конечно выкручусь, но для других "алконавтов" придётся ставить полную версию

drfaust:
Обновил дома розницу базовую до 2.2.2.12 и удивился. Выгружается 19 реквизитов и ещё к-то теги в <>
Завтра начну Експерименты с боевой 1С.

З.Ы. Ну и напугали же меня 1Сочники, я думал хана - или пиши сам, или покупай обработку...

Навигация

[0] Главная страница сообщений

[#] Следующая страница

Произошла ошибка благодарности
Думаю...
Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 
Перейти к полной версии