Главная категория > Компьютеры, сканеры ШК, Клавиатуры, принтеры и ПО и т.д.

Мелкие "Приблуды" для ККТ, облегчающие нашу жизнь

(1/1)

drfaust:
Приволокли Штрих-М-ФР-К. Теряет связь (естественно принесли без интерфейсного кабеля)
Зада протестировать связь. Долго перед ним сидеть и жать пимпачку не будеш.


Откопал пример теста для драйвера 4.10 версии и приписал одну процедурку в обработку 1С 7.7.
Открываем в конфигураторе обработку Штрих-М: Тест фискального регистратора для v 7.7 и в форме Отчёт.ОсновныеКоманды за 10 мин накидал:
Спойлер
--- Код: ---

Процедура ПоКнопкеТестСвязи();
   
   ТЧ="";ТМ="";Сек="";ТекущееВремя(ТЧ,ТМ,Сек);
   КонецЧаса=ТЧ+2;
   КонецМинуты=ТМ;
   
   Пока 1>0 Цикл
       //Печатаю строчку
      Caption="Тест связи в: "+ТЧ+":" + ТМ+":" + Сек;
      ПечатьСтроки();
     
      Если FR.ResultCode <> 0 Тогда
         Вопрос("Код ошибки : "+FR.ResultCode,1);
         Возврат;
      КонецЕсли;
      //Жду минуту
      Пока  КонецМинуты = ТМ Цикл
         ТекущееВремя(ТЧ,ТМ,Сек);
      КонецЦикла;   
      КонецМинуты=ТМ;   
   КонецЦикла;


КонецПроцедуры

--- Конец кода ---
Теперь ФР печатает строчку раз в минуту без моего участия. В случае ошибки 1С вякнет предупреждением. Из "вечного" цикла можно выйти выдернув СОМ-порт и через минуту увидим ошибку.

Bit:
Тестдрайвер Рязанского это не делает?

drfaust:
Нету его, надо будет поставить. А так и ленту отдам с распечаткой

Навигация

[0] Главная страница сообщений

Произошла ошибка благодарности
Думаю...
Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
Перейти к полной версии