Автор Тема: Мелкие "Приблуды" для ККТ, облегчающие нашу жизнь  (Прочитано 1083 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн drfaust

  • Резидент
  • Эксперт
  • ****
  • Сообщений: 2696
  • Похвалили: 82 раз(а)
  • Я не Шариков, просто судьба располосовала мой лоб.
  • Откуда: РФ, Лангепас, MSK+2 (UTC+5)
    • drfaust.asuscomm.com
Приволокли Штрих-М-ФР-К. Теряет связь (естественно принесли без интерфейсного кабеля)
Зада протестировать связь. Долго перед ним сидеть и жать пимпачку не будеш.


Откопал пример теста для драйвера 4.10 версии и приписал одну процедурку в обработку 1С 7.7.
Открываем в конфигураторе обработку Штрих-М: Тест фискального регистратора для v 7.7 и в форме Отчёт.ОсновныеКоманды за 10 мин накидал:
Спойлер

Процедура ПоКнопкеТестСвязи();
   
   ТЧ="";ТМ="";Сек="";ТекущееВремя(ТЧ,ТМ,Сек);
   КонецЧаса=ТЧ+2;
   КонецМинуты=ТМ;
   
   Пока 1>0 Цикл
       //Печатаю строчку
      Caption="Тест связи в: "+ТЧ+":" + ТМ+":" + Сек;
      ПечатьСтроки();
     
      Если FR.ResultCode <> 0 Тогда
         Вопрос("Код ошибки : "+FR.ResultCode,1);
         Возврат;
      КонецЕсли;
      //Жду минуту
      Пока  КонецМинуты = ТМ Цикл
         ТекущееВремя(ТЧ,ТМ,Сек);
      КонецЦикла;   
      КонецМинуты=ТМ;   
   КонецЦикла;


КонецПроцедуры
Теперь ФР печатает строчку раз в минуту без моего участия. В случае ошибки 1С вякнет предупреждением. Из "вечного" цикла можно выйти выдернув СОМ-порт и через минуту увидим ошибку.
« Последнее редактирование: 21/11/2013 16:17:25 от Bit »
Не кассами одними жив ЦТО ;-)
 

Оффлайн Bit

  • Администратор
  • Эксперт
  • *******
  • Сообщений: 1560
  • Похвалили: 99 раз(а)
Тестдрайвер Рязанского это не делает?
 

Оффлайн drfaust

  • Резидент
  • Эксперт
  • ****
  • Сообщений: 2696
  • Похвалили: 82 раз(а)
  • Я не Шариков, просто судьба располосовала мой лоб.
  • Откуда: РФ, Лангепас, MSK+2 (UTC+5)
    • drfaust.asuscomm.com
Нету его, надо будет поставить. А так и ленту отдам с распечаткой

Не кассами одними жив ЦТО ;-)
 

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20